Wednesday, October 24, 2012

Version 0.58.1a Bug List

Please post 0.58.1a's bugs in this post.

Fix that didn't make it in 0.58a : Better localization for Switzerland / Austrian German (sorry ><, I didn't forget though)


Stats on Version 058a reported bugs:

4 / 10 Fixed Bugs

10 / 16 Bugs Verified

0 Non-Reproducible Bug(s)

0 "Not-A-Bug"

16 Reported Bugs



(D Orc)

I started a new game, chose to play a male (chose cock and testicles, did not select pussy or tits). My cock is 7 inches, my testicles are 3. Started game. Right off the bat, I noticed that there are no male arousal images. Later, while at the park, I took part in an orgy and got the bukkake schene. It displayed the female version of the scene (though you don't have a cock...) and left me covered in cum.

All of my descriptive text reads correctly, and I get the 'male' pictures for the shower, but otherwise it seems confused as to my gender.

Status: Unverified

(TK)

Ingesting a priapus shroom as a female grants two cocks instead of one.

Status: Verified

-inches is still being removed by the script reader.

Status: Verified

There is debug text (1, 2, ..., 8) left in some loot events.

Status: Verified

(Anon)

The futabus essence seems to grant a cock type despite that it currently doesn't grant a cock.

Status: Unverified

When an attribute drops below 0, it causes crashes on the new attribute screen.

Status: Fixed

(Anon)

The dirt status effect from the northern highway is not being washed away.

Status: Fixed

(Anon)

When creating a character, choosing "farm" as a job doesn't work.

Status: Fixed

(Lord Aethar)

Addendum: I started a new game and as soon as I could, I purchased a couple pieces of equipment and realized something in the info window that pops up.

In the previous game, it says, "Equipment Purchased" but doesn't list what exactly was purchased (but EP's are deduced as I mentioned earlier). In the new game, it says the proper, "You have gained a piece of equipment..." followed with the name of the equipment in question and then the "Equipment Purchased" message.

With the new game, saving, loading and/or quit/loading the game hasn't triggered any problems with equipment. I've both saved over the previous save, and saved to a new filename. The old game remains broken despite any amount of saving/reloading.

Addendum #2: I just had the issue hit my new game again, but fortunately it didn't seem to get "baked" into my saved game. I didn't do much after saving - I wandered in the sewers a bit, killed a couple critters (using longbow & greatsword), camped once, ran from an alligator, then returned to the marketplace, sold some of my extra equipment. It was when I went to buy a Large Shield that the bug hit again. I quit the game immediately and reloaded my game, and everything was fine.

The one commonality that I can see between my old save and my new save is the Combat. Old save, I hadn't bought any gear yet, so the couple combats had my old character either running for her life, or being handily defeated.

New character has lost a few combats, but has won several too.

Next time I have the bug happen, I'll try to make a new save so perhaps two separate saves of the same character could reveal something.


Addendum #3: I finally had some time to look into my games a little more. The issue that showed-up in Game #2 isn't quite the same as what happened in Game #1, but may still be related.

In Game #2, the info box does indeed stop reporting what you're buying, but the items are still showing up in the equipment lists as they're supposed to (unlike in game #1, where the equipment never shows up).

Furthermore, I found that I can reliably trigger this behavior by selling equipment. It doesn't seem to matter what I sell either. Furthermore, once this happens, it seems to get baked into the save game, since reloading a game after selling exhibits the same behavior.

I have two saves I can e-mail to you Tac0, one immediately prior to the bug, and one immediately after that. Again, it's not *quite* the same as the problem I had in Game #1, but it does have similarities.

Status: Unverified



(XLII)

I've been having trouble since even before this build. Whenever I give my characters vulpine attributes, it seems like you can't change the tail to feline through any means. I've tried the solutions ward, as well as copious neko fruit, but I just can't figure it out. Is this a but, or am I just doing something wrong?

Status: Unverified

(Anon)

Self Tit-fucking is always an option at the Nameless Inn regardless of arousal.

Status: Verified

(Giantris)


No equipment-being-lost bug, but sometimes when I sell equipment I get an error. This specific time selling the items one by one seems to stop the error, but I'll keep testing various things to see if I can narrow down exactly what causes it.

Found it. I think. Wasn't selling equipment at all, it was trying to travel while having this specific weapon equipped. (Sad, cause it's a REALLY good weapon)

"System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary."

Made a copy of the save file in case you need it.

Status: Verified, but only replicated once. I made a change to the way menus spawn and I hope that prevents future errors. Menus should not appear when traveling because I was afraid stuff like this could happen...though I'm not saying I fixed this bug yet :P.

(Giantris)

Also, so far every time I exit combat in the sewers, the "move locations" from the previous area stay up. That causes a "Object reference not set to an instance of an object." error, but all you have to do is hit "travel/sleep" again and the correct location map comes up.

Status: Unverified

(Slater & Anon)

There is a bug in the sewers where you receive an error after moving.

Status: Unverified

There is a slowdown in some locations due to loading images.

Status:  Verified 

(Anon)

If we get the statute from the odd job before meeting the spirit in the park and always deny the spirit after that, the resulting text seems to assume a different history of events.

Status: Unverified

Orcish and Gyno potions use two items isntead of one.

Status: Fixed


39 comments:

  1. All combat gives me an Unhandled Exception error, either right away or as soon as I press continue:

    ************** Exception Text **************
    System.OverflowException: Value was either too large or too small for a Decimal.
    at System.Decimal..ctor(Double value)
    at ptk.CombatFunctions.SetConsiderLabel()
    at ptk.CombatFunctions.RefreshCombatWindow(Boolean skipTurnCheck)
    at ptk.Combat_LoadEnemy.LoadFoe(Int32 EnemyReference, Int32 StartingDistance, Boolean PlayerFirst)
    at ptk.sysFunctions.ExecuteEvent(PornariumEvent SentEvent, Boolean FromActions)
    at ptk.Main.MContinue_Click(Object sender, EventArgs e)
    at System.Windows.Forms.Control.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnClick(EventArgs e)
    at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
    at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
    at System.Windows.Forms.Control.WndProc(Message& m)
    at System.Windows.Forms.ButtonBase.WndProc(Message& m)
    at System.Windows.Forms.Button.WndProc(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
    at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
    at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

    ReplyDelete
  2. Encountered a few bugs:

    I started a new game, chose to play a male (chose cock and testicles, did not select pussy or tits). My cock is 7 inches, my testicles are 3. Started game. Right off the bat, I noticed that there are no male arousal images. Later, while at the park, I took part in an orgy and got the bukkake schene. It displayed the female version of the scene (though you don't have a cock...) and left me covered in cum.

    All of my descriptive text reads correctly, and I get the 'male' pictures for the shower, but otherwise it seems confused as to my gender.

    ReplyDelete
  3. Strange, thanks for letting me know :)

    ReplyDelete
  4. My character is covered in grime from exploring the great northern and no amount of showers will get her clean. Showering will remove cum though.

    ReplyDelete
    Replies
    1. Can confirm that one.
      Status effect is:
      You are covered with dirt and grime...you REALLY could use a shower (-8 appearance penalty)

      Delete
    2. That is correct. Unless there is some way to do it in game but I would assume showering would fix it.

      Delete
    3. Showering should fix it, though this is a bug (thankfully a very easy one to fix, it'll be in the next build)

      Delete
  5. I encountered a similar problem as D'Orc. I started a game as a futanari, with with a penis, testicles, vagina and breasts. Despite this the same event in the park believed my character did not have a penis and gave the same scene as D'Orc's character. The game so far only seams to be confused with regards to the orgy event in the park and so it may be defaulting to that scene.

    ReplyDelete
  6. When creating a character, choosing farm as your job doesn't work.

    ReplyDelete
  7. (1) Equipement bug is still there. After saving the game new (bought) equipement won't show in the equipement management window. I don't get it, what could go wrong here - why majority of gamers don't get this bug.
    Sys info:
    WinXP Pro SP3
    Microsoft .NET Framework 2.0 Service Pack 1 2.1.21022
    Microsoft .NET Framework 2.0 Service Pack 1 Language Pack 2.1.21022
    Microsoft .NET Framework 3.0 Service Pack 1 3.1.21022
    Microsoft .NET Framework 3.0 Service Pack 1 Language Pack 3.1.21022
    Microsoft .NET Framework 3.5
    Microsoft .NET Framework 4 Client Profile 4.0.30319
    Microsoft .NET Framework 4 Extended 4.0.30319
    Microsoft Visual Basic PowerPacks 10.0
    Microsoft Visual C++ 2008 Redistributable - x86 9.0.21022
    Microsoft Visual C++ 2010 x86 Redistributable - 10.0.40219

    Any clue here?

    ReplyDelete
    Replies
    1. I'm having the same problem. Started a new game, and have played for a couple hours. I just went to buy some equipment, but it doesn't seem to appear in my inventory and thus I can't equip it.

      The EP's are deducted as they should be... just no equipment :(

      Delete
    2. I keep scratching my head on this one myself, I cannot reproduce this bug at all myself. I've reproduced other EQ bugs but never this one.

      Your problem occurs only when saving though correct? That may help me narrow it down.

      Delete
    3. Addendum: I started a new game and as soon as I could, I purchased a couple pieces of equipment and realized something in the info window that pops up.

      In the previous game, it says, "Equipment Purchased" but doesn't list what exactly was purchased (but EP's are deduced as I mentioned earlier). In the new game, it says the proper, "You have gained a piece of equipment..." followed with the name of the equipment in question and then the "Equipment Purchased" message.

      With the new game, saving, loading and/or quit/loading the game hasn't triggered any problems with equipment. I've both saved over the previous save, and saved to a new filename. The old game remains broken despite any amount of saving/reloading.

      Delete
    4. Addendum #2: I just had the issue hit my new game again, but fortunately it didn't seem to get "baked" into my saved game. I didn't do much after saving - I wandered in the sewers a bit, killed a couple critters (using longbow & greatsword), camped once, ran from an alligator, then returned to the marketplace, sold some of my extra equipment. It was when I went to buy a Large Shield that the bug hit again. I quit the game immediately and reloaded my game, and everything was fine.

      The one commonality that I can see between my old save and my new save is the Combat. Old save, I hadn't bought any gear yet, so the couple combats had my old character either running for her life, or being handily defeated.

      New character has lost a few combats, but has won several too.

      Next time I have the bug happen, I'll try to make a new save so perhaps two separate saves of the same character could reveal something.

      Delete
    5. Addendum #3: I finally had some time to look into my games a little more. The issue that showed-up in Game #2 isn't quite the same as what happened in Game #1, but may still be related.

      In Game #2, the info box does indeed stop reporting what you're buying, but the items are still showing up in the equipment lists as they're supposed to (unlike in game #1, where the equipment never shows up).

      Furthermore, I found that I can reliably trigger this behavior by selling equipment. It doesn't seem to matter what I sell either. Furthermore, once this happens, it seems to get baked into the save game, since reloading a game after selling exhibits the same behavior.

      I have two saves I can e-mail to you Tac0, one immediately prior to the bug, and one immediately after that. Again, it's not *quite* the same as the problem I had in Game #1, but it does have similarities.

      Delete
    6. Thanks LordAethar, I appreciate the detailed post! Gives me a lot to work with so I can hopefully nail this bug for good :P.

      I would absolutely appreciate the saves, but with the save(s) could you also send the .peqdb file with the same name? It will also give me some useful debug information, just need to narrow down where it's occuring.

      (Also, some old saves may be bugged by this patch, I honestly didn't consider that outcome ><.)

      Delete
    7. E-Mail sent. If I have any other insight, I'll let you know.

      Delete
  8. I've been having trouble since even before this build. Whenever I give my characters vulpine attributes, it seems like you can't change the tail to feline through any means. I've tried the solutions ward, as well as copious neko fruit, but I just can't figure it out. Is this a but, or am I just doing something wrong?

    ReplyDelete
  9. Self-titfuck is always available in the Nameless Inn room (regardless of arousal).

    ReplyDelete
  10. The Orcish and Gyno potions consume 2 of the potions from your inventory whenever you use either.

    ReplyDelete
  11. No equipment-being-lost bug, but sometimes when I sell equipment I get an error. This specific time selling the items one by one seems to stop the error, but I'll keep testing various things to see if I can narrow down exactly what causes it.

    ReplyDelete
    Replies
    1. Found it. I think. Wasn't selling equipment at all, it was trying to travel while having this specific weapon equipped. (Sad, cause it's a REALLY good weapon)

      "System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary."

      Made a copy of the save file in case you need it.

      Delete
  12. Also, so far every time I exit combat in the sewers, the "move locations" from the previous area stay up. That causes a "Object reference not set to an instance of an object." error, but all you have to do is hit "travel/sleep" again and the correct location map comes up.

    ReplyDelete
  13. The dirt and grime status effect from the highway event isn't removed in the shower

    ReplyDelete
  14. If Bell takes you home, and you successfully arouse her, you will temporarily have a cock even if you do not otherwise have one. (Also, you break out of her encounters (in the bar or in her house) if you do not have enough fatigue points.)

    ReplyDelete
  15. I never get in trouble for losing control of myself in the park. I do not mind my evasive nature, but probably either the warning about particularly strict law enforcement should be changed, or I should be getting in trouble?

    ReplyDelete
  16. I played this for quite a while and at some point when i was outside pornicle on the mile30/mile45 or perhaps it was the nameless inn (not sure when it happened) but i lost all my magic spells. Later when i got back to the apartment i used the debug to reset all spells. This worked and i managed to recover all the spells you can learn from the teachers at the tower of fallos, however i am unable to recover the spells gained from the travellers on Mile:30 as my character interacts with them as though they have already met so i can never telepathically talk with them again. I think talking to the old mage at the nameless inn might've caused it but thats just a guess and i have no concrete proof that it is. Also the chosen one or whatever they were called has since stopped appearing...unless fighting him and beating him results in me never seeing them again?

    I can confirm 3 previously mentioned bugs which are the

    1. dirt bug "You are covered with dirt and grime...you REALLY could use a shower (-8 appearance penalty)"
    2. the movement bug in sewers where it generates an error trying to move after a fight with mobs in sewer. Which can be worked around by clicking on the "travel/sleep" button which updates the player's position to the correct location.
    3. the orgy scene in the park playing a female version of an orgy scene despite my character being a futa, thus having a cock, even though the scene says i don't.

    There's another issue that i'm not sure whether or not its my computer or the game. But the game seems to run significantly slower when inside the apartment or inside a room in the nameless in. Compared to previous versions where all options occured pretty much instantly when selected, in this version there's like a 1-2 second extra waiting time after clicking continue before i can select another option. I guess this might be due to the extra pictures that have been added since there's a few pictures for each respective action. Not sure though...

    ReplyDelete
    Replies
    1. Thanks for the bug reports :)

      You are correct that the lag time is due to additional images. I probably don't use the most efficient way of loading them. I'll definitely work on fixing that with the next build :)

      Delete
  17. Hey Taco, I was away for a while,(Its Voxination by the way) I realized just now download page still says its 45a.... such as,

    "(NEW) Pornarium 0.45a Game Download (Torrent, recommended)
    (New) Pornarium 0.45a Game Download (not recommended)
    Pornarium v0.43a Game Download (old)"

    I'm totally confused about which i have to download to play...I tried the torrent file, torrent extension also says its 045a Just where the hell people download new versions...

    ReplyDelete
    Replies
    1. And I realized you finally started to work on modifying home, buying a new home and having NPC's move in with you, I can only assume that Upgrade system is nearby too, heh took you long enough to complete other suggestions I guess.

      Delete
    2. And you should sometimes check the site, there is still old stuff lying around, in download page "Latest Alpha Release (Version 0.35a)" and "Pornarium v.043a Buglist" in important links list.

      Delete
  18. If we get the statute from the odd job before meeting the spirit in the park and always deny the spirit after that, the resulting text seems to assume a different history of events.

    ReplyDelete
  19. Thanks for all the bug reports. I can't seem to reproduce the equipment error on selling (at least reliably). I was able to do so once but since then...nothing ><

    ReplyDelete
    Replies
    1. First bug: Performing an action after equipping a Well-Made Iron Greatsword of Force after selling my original Iron Greatsword.

      Repeated bug: Performing an action after equipping a Well-Made Iron Greatsword of *the Siren* after selling my original Iron Greatsword.

      Things that do not cause bug:

      - Selling basic Iron Greatsword and equipping something else.
      - Not equipping Well-Made Iron Greatsword at all after selling basic Iron Greatsword

      However:

      - Equipping Well-Made Iron Greatsword while the basic Iron Greatsword actually just equips the basic one

      THEREFORE

      I think it's something specifically involving Well-Made Iron Greatswords, and defaulting to the basic one

      or something

      this took me way too long to figure out and i am very tired now, and god i hope you read this haha

      Delete
    2. SECONDARY REPORT:

      Actually equipping ANYTHING after selling my basic iron greatsword crashes the game

      because equipping anything other than an Iron Greatsword immediately reverts my weapon equip to an Iron Greatsword. So, if I have no Iron Greatsword and I try and do anything, it's like "But you're using an Iron Greatsword but you don't have an Iron Greatsword MY LIFE IS A LIE" and crashes.

      Want my savefile again so you can figure out why I apparently have an Iron Greatsword superglued to my character's hands? (I had to copy-paste Iron Greatsword too many times)

      Delete
    3. Thanks for all the effort you've taken to replicate this. I'm going to try to do so on my end and hopefully will quash the bug for good.

      I produced it once randomly and I can see why it's annoying :P I was just selling equipment and BAM crash everything was lost ><

      I'm not certain yet if I'll need an additional save file or not (I'd feel bad for even asking after all the work you did). I'll see what I can do with the two save files you gave me prior :)

      Delete
    4. Eh, if you do it's no big deal. Once I sussed it out I saved an alternate file at the point of bug in a different place so that I wouldn't overwrite it.

      Delete
    5. I would like your save file :P This is one hell of a tricky bug to quash. Hawtstuff just generated (after I tried despite these steps) and still no luck duplicating it after that one time. It seems though that greatswords may be the likely culprit.

      Delete
    6. Nevermind, think I finally isolated it! I'm afraid to say it's fixed yet but with some future testing it may just be.

      Basically when your EQ list refreshes if you have a greatsword equipped it checks to see if you have a shield equipped. If you do (Which actually in this case you didn't, another bug) it attempts to change your Melee weapon back to fists, which is listed as "1: Fists" by the code. In actuality, in your equipment file it's listed as " 1: Fists" instead. For this one piece of equipment it causes an error and results in this rare crash.

      I just need to make sure it's not more widespread before applying the fix. If the extra space causes an error in multiple cases and not just the shield, I need to figure out how to eliminate it in every instance instead of this one case :P

      Delete

Follow us by Email!

Total Visitors